Status Page
Get updates
Status
Incidents
September – November 2025
November 2025
Help Center unreachable
MINOR
affected
Help Center
lasted
9min 55s
The incident has been resolved
resolved
Nov 21 21:00:28 (UTC)
resolved
+1 update message
Public website unreachable
MEDIUM
affected
Public Website
lasted
9min 53s
The incident has been resolved
resolved
Nov 19 12:53:50 (UTC)
resolved
+1 update message
Public website unreachable
MEDIUM
affected
Public Website
lasted
9min 55s
The incident has been resolved
resolved
Nov 19 11:23:51 (UTC)
resolved
+1 update message
Web Application Unresponsive
CRITICAL
affected
Web App
lasted
1h 27min 56s
The incident has been resolved
resolved
Nov 18 14:35:30 (UTC)
resolved
+1 update message
Web Application Unresponsive
CRITICAL
affected
Web App
lasted
6min 48s
The incident has been resolved
resolved
Nov 18 12:54:24 (UTC)
resolved
+1 update message
Web Application Unresponsive
CRITICAL
affected
Web App
lasted
6min 50s
The incident has been resolved
resolved
Nov 18 12:14:26 (UTC)
resolved
+1 update message
Web Application Unresponsive
CRITICAL
affected
Web App
lasted
6min 47s
The incident has been resolved
resolved
Nov 18 11:44:24 (UTC)
resolved
+1 update message
October 2025
No incidents reported
September 2025
No incidents reported
Powered by
Checkly